CAC verification on Kuda for Business is Delayed

Incident Report for Kuda

Resolved

This incident has been resolved
Posted Sep 01, 2025 - 08:55 CET

Identified

We are having an issue with verifying CAC documents. We are working with our partner to resolve this soonest.
Posted Aug 26, 2025 - 18:38 CET
This incident affected: Onboarding (Business Registration with CAC).