Kuda Status – Is Kuda Down? | Check Kuda Network

GLO OTPs Delivery Failure

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Sep 13, 2026 - 19:28 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2026 - 19:20 CET

Identified

OTP delivery for users on the GLO network is currently down due to an upstream carrier failure. We are working with the provider to resolve this soonest.
Posted Sep 13, 2026 - 15:16 CET
This incident affected: One Time Passcodes (OTP) (SMS One-Time-Passcodes (OTPs)).

151 Herbert Macaulay Way, Yaba, Lagos,
Nigeria

91 Wimpole Street, London W1G 0EF
UK

Kuda.

Get the App