MTN Airtime and Data purchases are failing

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jan 03, 2026 - 12:17 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 03, 2026 - 12:06 CET

Identified

MTN Airtime and Data purchases are failing. We are reversing all failed MTN airtime and data purchases.
Posted Jan 03, 2026 - 11:38 CET
This incident affected: Bills (Airtime Purchase, Internet).