Service Degradation Affecting Transactions

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 15:40 CET

Update

We are continuing to monitor for any further issues.
Posted Dec 10, 2025 - 14:20 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 13:03 CET

Investigating

We are experiencing some connection issues with our payment partner at the moment. While we are looking into it, this is affecting transfers into your Kuda account as well as some transfers out of your Kuda account.

For transfers out of your Kuda account, Kuda-to-Kuda, Kuda-to-PalmPay, Kuda-to-OPAY, Kuda-to-Zenith Bank, Kuda-to-GTB, Kuda-to-Fidelity Bank, Kuda-to-Moniepoint transfers are available
Posted Dec 10, 2025 - 10:44 CET
This incident affected: Transfers (Kuda to Other Banks Transfers, Other Banks to Kuda Transfers).