Service Degradation Affecting Transfers
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 20:18 CET
Identified
NIBSS, the settlement partner for all banks, is fixing a downtime but Kuda-to-Kuda and Kuda-to-PalmPay Kuda-to-OPAY, Kuda-to-GTB, Kuda-to-Access Bank, Kuda-to-Zenith Bank and Kuda-to-Moniepoint transfers are available
Posted Jan 12, 2025 - 08:42 CET
This incident affected: Transfers (Kuda to Other Banks Transfers, Other Banks to Kuda Transfers).