Scheduled Maintenance

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted May 27, 2026 - 00:59 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2026 - 00:32 CET

Identified

Transaction History Service will be undergoing maintenance from 12:00 am to 01:00 am tomorrow. Service would be restored as soon as we are done with the maintenance.
Posted May 26, 2026 - 20:25 CET
This incident affected: Transaction History.