CAC verification on Kuda for Business is Delayed

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 19:50 CET

Update

We are continuing to work on a fix for this issue.
Posted Aug 01, 2025 - 14:35 CET

Identified

We are having an issue with verifying CAC documents. We are working with our partner to resolve this soonest.
Posted Jul 29, 2025 - 09:23 CET
This incident affected: Onboarding (Business Registration with CAC).