Service Degradation Affecting Transactions

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 00:43 CET

Monitoring

Transfers are now being processed successfully. A few transactions from the earlier connection issue remain pending, and we’re working to clear them quickly.
Posted Feb 02, 2026 - 19:25 CET

Identified

We are experiencing some connection issues with our payment partner at the moment. While we are looking into it, this is affecting transfers out of your Kuda account. However, Kuda-to-Kuda, Kuda-to-PalmPay, Kuda-to-OPAY, Kuda-to-Zenith Bank, Kuda-to-GTB, Kuda-to-Fidelity Bank, Kuda-to-Moniepoint transfers are available
Posted Feb 02, 2026 - 19:00 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).