Service Degradation Affecting Transfers

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 02:37 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 23:53 CET

Identified

We are experiencing intermittent transaction delays due to a widespread service issue with NIBSS. Some transactions to and from your Kuda account may be delayed. We are working with our providers to resolve this quickly.
Posted Jun 05, 2026 - 17:56 CET
This incident affected: Transfers (Kuda to Other Banks Transfers, Other Banks to Kuda Transfers).