Some users are unable to sign into their Kuda Retail app

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 16:38 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 22:50 CET

Identified

Update!!! We have isolated this to some users on the MTN network, and we are working with our partners, MTN included to resolve
Posted Jul 09, 2025 - 12:11 CET

Investigating

We have detected an issue with login affecting a couple of users... More updates to follow
Posted Jul 09, 2025 - 12:00 CET
This incident affected: Login Method (Passcode Login, Username/Password Login, Web Login).