MTN Airtime and Data Purchases Failing
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Mar 17, 2024 - 08:17 CET
Identified
Some MTN airtime and data purchase payments are currently failing. We are reversing failed transactions, while we sort this out with the service provider.
Posted Mar 15, 2024 - 12:29 CET
This incident affected: Bills (Airtime Purchase, Internet).