MTN Airtime and Data Purchases are Pending
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Mar 02, 2024 - 13:44 CET
Identified
Some MTN airtime and data purchase payments are currently pending. We'll be reversing unprocessed payments, while we sort this out with the service provider.
Posted Mar 02, 2024 - 12:17 CET
This incident affected: Bills (Airtime Purchase, Internet).