Issue Displaying In-App Transaction History

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 09:58 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 08:20 CET

Identified

We’re aware that some users are currently unable to view their transaction history in the mobile app. Our team is working to resolve this as quickly as possible.
Posted Jul 23, 2026 - 07:20 CET
This incident affected: Transaction History.