Service Degradation Affecting Transfers

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Oct 18, 2024 - 08:49 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2024 - 08:20 CET

Investigating

Some transfers to Kuda from Kuda are failing temporarily. We’re working on fixing this as quickly as possible. Please, hold on for a status update.
Posted Oct 18, 2024 - 07:58 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).