Delay in Processing Transactions

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted May 19, 2025 - 22:04 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2025 - 22:01 CET

Identified

Transfers to/from other banks might experience a slight delay due to downtime with the settlement partner.
Posted May 19, 2025 - 17:19 CET
This incident affected: Transfers (Kuda to Other Banks Transfers, Other Banks to Kuda Transfers).