Degraded Performance: Business App Sign-In

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 23:00 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 22:50 CET

Identified

Sorry, you might not be able to sign in to the business app now. We’re working to fix this error
Posted Jul 03, 2026 - 22:28 CET
This incident affected: Kuda Business Services (Login).