Scheduled Maintenance

Incident Report for Kuda

Resolved

The maintenance has been successfully completed, and all outward transactions are being processed successfully.
Posted Nov 19, 2025 - 01:30 CET

Identified

There is an ongoing maintenance activity happening on some of our services. While this is ongoing, you won't be able to send money to other banks, but you'll be able to receive money. The maintenance won't affect transfers between Kuda accounts.

Transfers to other banks would be restored as soon as we are done with the maintenance.
Posted Nov 19, 2025 - 00:13 CET
This incident affected: Transfers (Kuda to Other Banks Transfers) and Kuda Business Services (Outward Transfers (Bulk)).