Some Banks Are Not Processing Transfers Sent to Them
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 11:34 CET
Identified
Some transfers from Kuda to Opay are failing temporarily and we’re reversing all failed transactions. Please, don’t retry the transfer until the status update changes.
Posted Mar 14, 2024 - 09:39 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).