Chats and Emails to Support Team Are Not Being Delivered.
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 07:39 CET
Identified
Chats and email to our support team are not being delivered. We are looking into this with our service provider to sort it out soonest.
Posted Nov 05, 2024 - 07:07 CET
This incident affected: Support Center (Live In-App Chats, Emails).