USA Apple Gift Card Purchase is failing.
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Apr 28, 2024 - 17:02 CET
Identified
Apple USA payments are currently failing. We’re reversing all failed payments while we sort this out with the service provider.
Posted Apr 25, 2024 - 17:19 CET
This incident affected: Bills (Gift Cards).