Service Degradation Affecting Transactions

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 01:33 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 23:20 CET

Investigating

Sorry, you can’t make transactions because we’re currently fixing a downtime. We’ll let you know as soon as you can.
Posted Jul 02, 2025 - 20:20 CET
This incident affected: Bills (Airtime Purchase, Internet) and Transfers (Kuda to Other Banks Transfers, Other Banks to Kuda Transfers).