Pending Outward Transfer

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Apr 11, 2026 - 11:40 CET

Monitoring

We are aware that some transactions processed are pending due to a downtime with our processor. Please don’t worry, we are working to process them shortly or ensure a reversal is made to your account
Posted Apr 10, 2026 - 22:49 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).