Delay in Inward Transactions

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 08:49 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 12, 2026 - 07:45 CET

Identified

An issue with delay in Inwards transactions has been observed and our engineers are working to resolve this swiftly.
Posted Jul 12, 2026 - 05:55 CET
This incident affected: Transfers (Other Banks to Kuda Transfers).