Service Degradation Affecting Retail Service

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted May 16, 2026 - 11:32 CET

Update

We are continuing to investigate this issue.
Posted May 11, 2026 - 10:26 CET

Investigating

Our teams are currently investigating an issue causing intermittent instability on some services within the app. While our services are generally online, some users are experiencing delay behavior with transfer, bill purchase and cards.
Posted May 08, 2026 - 12:22 CET
This incident affected: Cardless Payment (Pay with bank, Pay with USSD, POS Terminal Payment, ATM Withdrawal), Bills (Airtime Purchase, Betting, Electricity, Internet, TV, Gift Cards, Education, Transportation and Tolls), and Transfers (Kuda to Other Banks Transfers).