Service Degradation Affecting Transfers
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Nov 29, 2024 - 22:25 CET
Identified
NIBSS, the settlement partner for all banks, is fixing a downtime but Kuda-to-Kuda and Kuda-to-PalmPay, Kuda-to-Opay transfers are available
Posted Nov 29, 2024 - 20:57 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).