MTN OTPs Are Delayed

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 23:44 CET

Identified

MTN OTPs might be delayed. We are working with the team to resolve this soonest
Posted Oct 16, 2025 - 20:03 CET
This incident affected: One Time Passcodes (OTP) (SMS One-Time-Passcodes (OTPs)).