Kuda Status – Is Kuda Down? | Check Kuda Network

Account Statement Generation Unavailable

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Sep 05, 2026 - 12:17 CET

Update

We are continuing to monitor for any further issues.
Posted Sep 05, 2026 - 11:44 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2026 - 11:44 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 05, 2026 - 11:17 CET

Investigating

We are currently experiencing an issue affecting account statement generation for some users. Our engineering team is actively investigating, and we will provide an update as soon as more information is available
Posted Sep 05, 2026 - 10:07 CET
This incident affected: Account Statements (Retail).

151 Herbert Macaulay Way, Yaba, Lagos,
Nigeria

91 Wimpole Street, London W1G 0EF
UK

Kuda.

Get the App