Business Transaction Notifications Are Delayed

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 13:48 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 12:40 CET

Identified

We’re fixing delayed transaction notifications and will let you know when the fix is complete
Posted Apr 13, 2026 - 17:09 CET
This incident affected: Alerts and Notification (Business Transaction Alerts (Push Notifications), Business Transaction Alerts (Email)) and Transaction History.