Maintenance in progress

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 01:13 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 00:46 CET

Identified

A scheduled maintenance is in progress, Business Api, web apps and the website may be unavailable within that period. Full service would be restored once the exercise is completed.
Posted Apr 17, 2026 - 00:06 CET
This incident affected: Web Apps (Retail Web App, Business Web App), Transfers (Open API), and Website.