Some Kuda Card Transactions Are Failing

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jun 14, 2026 - 08:16 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2026 - 06:47 CET

Update

We are continuing to work on a fix for this issue.
Posted Jun 14, 2026 - 00:44 CET

Identified

Some transactions from Kuda Cards are failing temporarily and we’re reversing all failed transactions. Please, don’t retry the transfer until the status update changes.
Posted Jun 14, 2026 - 00:35 CET
This incident affected: Cards (Card Transactions (NG), Physical Cards Request (NG), Virtual Cards Request (NG)).