Some Cards Transactions are Failing

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 10:31 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 10:22 CET

Identified

We are currently experiencing a connectivity issue with one of our partners. As a result, some card transactions are failing or not reaching our system. Our team is actively working to restore the connection. We apologize for the disruption and will provide updates here.
Posted Jun 04, 2026 - 09:48 CET
This incident affected: Cards (Card Transactions (NG)).