Partial Degradation on Savings on Retail Services
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 20:37 CET
Identified
Some customers are intermittently unable to create savings account or withdraw from existing savings. We’re looking into this, and we’ll fix it as soon as possible.
Posted Feb 20, 2024 - 16:09 CET
This incident affected: Savings Plans (Spend And Save, Save As You Want, Save Frequently, Fixed Deposits).