Transaction Notification Error

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 00:00 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2025 - 23:41 CET

Identified

We’re fixing delayed transaction notifications
Posted Dec 16, 2025 - 23:21 CET
This incident affected: Alerts and Notification (Transaction Alerts (Email), Transaction Alerts (Push Notifications)).