MTN OTPs Are Delayed

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 20:58 CET

Update

MTN OTPs are being delayed. We are working with the team to resolve this soonest
Posted Jun 18, 2025 - 20:41 CET

Identified

One Time Passcodes (OTP) - SMS One-Time-Passcodes (OTPs)
Posted Jun 18, 2025 - 20:40 CET
This incident affected: One Time Passcodes (OTP) (SMS One-Time-Passcodes (OTPs)).