MTN OTPs Are Delayed

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 13:48 CET

Identified

MTN OTPs are being delayed. We are working with the team to resolve this soonest
Posted Jun 14, 2025 - 13:01 CET
This incident affected: One Time Passcodes (OTP) (SMS One-Time-Passcodes (OTPs)).