Delay in Processing Overdraft Repayment

Incident Report for Kuda

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2026 - 15:57 CET

Identified

We’re currently experiencing a slight delay in processing these payments, but we're on it. Your balance will be updated as soon as things clear up. Thanks for your patience.
Posted Apr 11, 2026 - 15:16 CET
This incident affects: Overdraft.