Kuda Status – Is Kuda Down? | Check Kuda Network

Scheduled Maintenance

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 01:38 CET

Monitoring

The maintenance has been completed, and we are monitoring the performance
Posted Aug 20, 2026 - 00:39 CET

Identified

We are currently conducting essential system maintenance on our transfer services to improve performance and transaction stability.
Posted Aug 20, 2026 - 00:25 CET
This incident affected: Transfers (Kuda to Other Banks Transfers, Other Banks to Kuda Transfers).

151 Herbert Macaulay Way, Yaba, Lagos,
Nigeria

91 Wimpole Street, London W1G 0EF
UK

Kuda.

Get the App