Service Degradation Affecting Transfers
Incident Report for Kuda
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 12:29 CET
Identified
NIBSS, the settlement partner for all banks, is fixing a downtime but Kuda-to-Kuda and Kuda-to-PalmPay Kuda-to-OPAY and Kuda-to-Moniepoint transfers are available
Posted Dec 04, 2024 - 17:21 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).