Scheduled Maintenance

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 02:18 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 01:02 CET

Identified

Inward transfer on Business API, Retail and Business service will be undergoing maintenance from *12:00 am* to *01:00 am* tomorrow. Service would be restored as soon as we are done with the maintenance.
Posted Apr 08, 2026 - 18:00 CET
This incident affected: Transfers (Other Banks to Kuda Transfers, Open API) and Kuda Business Services (Inward Transfers).