Service Degradation Affecting Transfers

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Nov 01, 2024 - 08:04 CET

Identified

NIBSS, the settlement partner for all banks, is fixing a partial degradation with transfers, but Kuda-to-Kuda, Kuda-to-PALMPAY and Kuda-to-OPAY transfers are available
Posted Oct 31, 2024 - 11:37 CET
This incident affected: Transfers (Kuda to Other Banks Transfers).