Service Degradation Affecting Inward Transfers

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted May 04, 2026 - 21:27 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 21:19 CET

Identified

We are currently experiencing delays with inward transfers due to a service degradation at our settlement partner's end. We are in constant communication with them to expedite a resolution.
Posted May 04, 2026 - 14:30 CET
This incident affected: Transfers (Other Banks to Kuda Transfers).