IBEDC purchases are failing

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Oct 08, 2024 - 15:45 CET

Identified

IBEDC electricity tariff purchases are currently failing. We’re reversing all failed purchases while we sort this out with the service provider.
Posted Oct 08, 2024 - 10:57 CET
This incident affected: Bills (Electricity).