Some users are unable to sign into their Kuda Retail and Kuda Business app

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 01:34 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 23:20 CET

Investigating

Sorry, you might not be able to sign in to the app now. We’re working to fix this error.
Posted Jul 02, 2025 - 20:35 CET
This incident affected: Login Method (Passcode Login, Username/Password Login, Web Login, Retail Passkey Login, Business Passkey Login).