GLO Airtime and Data purchases are failing

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 22:33 CET

Identified

GLO Airtime and Data purchases are failing. We are reversing all failed GLO airtime and data purchases.
Posted Jun 27, 2025 - 19:45 CET
This incident affected: Bills (Airtime Purchase).