MultiChoice scheduled system upgrade

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 14:06 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 14:05 CET

Identified

We are writing to inform you that MultiChoice will be carrying out a scheduled system upgrade as outlined below:

Maintenance Window:
Sunday, 23rd November 2025 – 9:00 PM
to
Monday, 24th November 2025 – 10:00 AM

Impact:
All MultiChoice billing and payment services across all payment platforms will be temporarily unavailable throughout the maintenance period.

During this period, we will monitor the maintenance closely and provide updates once completed. In addition, please advise your customers to make Multichoice purchases before this period to avoid service disruption.

We regret any inconvenience this short notice may cause and appreciate your prompt attention to this matter.

Thank you
Posted Nov 23, 2025 - 10:41 CET
This incident affected: Bills (TV).