NIN Service on SmileID is down

Incident Report for Kuda

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 13:04 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 12:45 CET

Identified

NIN Service on SmileID is currently down, we are working with the ID authority to restore full service.
Posted Nov 06, 2025 - 11:17 CET
This incident affected: Self Help (Update My ID) and Kuda Business Services (Outward Transfers (Bulk), Transaction Approvals, POS - Pay with Bank, POS - Pay with USSD, POS - Pay with Card, Invoice - Create Invoice, Invoice - Pay with Bank, Invoice - Pay with Card, Login).